> > Bug (closed)

Rethink adjust page functions in upper right


Oct 15, 2006
Apr 15, 2012
Oct 15, 2006 / madlyr
Apr 15, 2012 / pixtur

Attached files

No files uploaded

original title: "Name 'status: Delete' instead of 'Delete' for task delete"π

Prio to v0.08:π

in TaskView:π

  • edit:
    • Task - required
    • Add Details (aka. Bug Report) - required but non intuitive
    • Move - required
  • status:
    • Delete - required
    • History - required sometimes


  • move the History button into the Details box and count versions of each item. E.g. "v.12 / View Item History"


Quick functions (on yellow tab) for task view have link 'status: Delete' instead plain 'Delete'.
edit:Task | Add Details | Move |  status: Delete  | History

It suggest, that we are deleting status, not task by using this fuction.

I think 'edit:Task' should be link with word 'edit'.
Now it suggest, that edit: is for all functions, not for edit Task.

Issue report

Have not tried



12 years ago

Yes, the current labeling is confusing... It came from a time, where tasks where not closed / approved / reopend by the QuickEdit form.

Maybe we should remove the "edit:" label as well?

madlyr:My vote for deleting edit: and status: - function names are self explanatory

12 years ago (2. update 12 years ago)

binder:refactor quick functions

12 years ago

we need to rethink, what functions should be listed in the different views.

after quickedit some are of no more use, but some more could be inserted?

pixtur:any suggestions?

12 years ago

binder:ok... let's go!

12 years ago

i think, we need a complete redesign for detail-pages - and quick functions (or what it's called anyway):

We should define a NAV2 for each NAV1. At present there's not a defined NAV2 everywhere. so it would be:


  • NAV1: home - projects - persons - companies ( - search)
    • NAV2/home: see
    • NAV2/projects: as is, but remove "history". more later
    • NAV2/persons: as is
    • NAV2/companies: as is

bread crumpπ

We should add a real bread crump to each page (as it is now in "taskView"). NAV2 should remain NAV2, but bread crump has to adjust the place, you're navigating at present.


  • the present linking is not consequent, but double and confusing, so we have two links for history in "taskView"...
  • history should instead be placed in quick functions for each item providing histories

quick functionsπ

We need to label the functions in the same way on every page. I don't know, how to name the grouping (was "edit" and "status", which are not quite accurate), but IMHO this would be the most reasonable list:
  • add new item
  • edit item
  • (edit item wiki): as this is part of any item, this link is optional?
  • edit item details (or label ist edit bug report?)
  • move (not only in current project, but also comments)
  • delete item
  • history (of item)
perhaps we could solve some issues with an AJAX-interface. So it could be for the projView
  • add
    • team member
    • new task
    • new bug
    • new effort
    • ...
With this, we saved some space...

pixtur:On labeling and structure...

12 years ago

I created a page for labeling of UI Elements (We should use precise labeling for discussions ;-) :
  • The "Functions"-Block in Home should go away, because it's bad.
  • I am not sure, if we need Page functions groups ala "edit:" ...
  • I took a while until I understood you point on "History".
-For the projects we might call this "Timeline" or "Changes".
  • For Tasks / Items it should not be a Page function because it is not an Action but just another view. I would place it in the details box.
    • Having breadcrumbs for other elements would be cool. I already implemented this for Files.
  • missing: implement correct Breadcrumbs for Efforts and Comments
  • my suggestion for the Page functions
    • "edit" (with Item or type)
    • "move"
    • "delete" / "undelete"
    • obsolete would be:
      • "add details" - this will be done automatically by the new task edit form like taskEdit_shaded.png
      • "edit wiki" - a lot of users do not know about wikis. We shoud avoid this term. The "Edit Description" button is much more clearer.
      • "history" - see above
  • using javascript for an "add"-menu would be cool. But mind the precise labeling. "New" creates something. "Add" reuses an existing item (e.g. a Person).

What do you think?

binder:Antwort auf On labeling and structure...

12 years ago (3. update 12 years ago)

let's clarify a bit:
I took a while until I understood you point on "History".

from pixtur

It was not double labeling, but double showing on one page. History as a term is OK for me. But it should only appear in the right context. Sorry, I wasn't specific enough. on "taskView" at present you see "History" in Pages and in Page Functions. Deleteing "History" from Pages is all I was about to do here! ;)
using javascript for an "add"-menu would be cool. But mind the precise labeling. "New" creates something. "Add" reuses an existing item (e.g. a Person).

from pixtur

you're perfectly right! I was too fast with writing! ;)

pixtur:I started to move add the version string to the task details block

12 years ago

  • Removed the "History"-Page function
  • Other page functions needs to be cleaned up

pixtur:seems to be done already. Closed

12 years ago